Joomlatools Support Center

Import from Docman 1.5.15 to Docman 3.1.2

Hi,

i have to export >1300 documents from docman 1.5.15 and import it in docman 3.1.2. How is that possible?

The old version 1.5.15 runs on joomla 1.5.26 and docman 3.1.2 runs on joomla 3.8 on another server.

i installed docman importer 2.1.2 on the new joomla 3.8. -> the import is not complete, some documents are missing.

when i use the import function in docman 3.1.2, i get an error message "RuntimeException with message 'JSON export file not found' in ..\libraries\joomlatools-components\migrator\controller\behavior\uploadable.php:22"

after selecting the export file.

Answer

Posted 2 years ago by Arunas Mazeika Staff

Hello Nils,

You first need to migrate your 1.5 install to DOCman 2.0. Here's the guide for this: http://help.joomlatools.com/article/104-docman-1x-to-docman-2x

After migrating to DOCman 2.0 you'll just need to upgrade to the latest 2.x version then upgrade again to DOCman 3.0.

I hope this helps.

There are 5 more comments in this ticket.
Subscribe or login to join the discussion!

Nils Vielkind
25.09.17
Answered

System Information

3.1
3.8
n/a
n/a