Joomlatools Support Center

Strict Standards Error messages in DOCman

Hi,

I´m using XAMPP 1.7.7 , PHP version is 5.3.8 and Joomlaversion is 2.5.7. The DOCman version is the latest 1.6.6, When I set the error reporting in Joomla to "Simple", everything seems to work fine, but when I set error reporting to "Maximum" or "Development" I get a lot of error message. Here is some examples:

Strict Standards: Declaration of mosDMDocument::load() should be compatible with that of JTable::load() in C:\joomla\administrator\components\com_docman\docman.class.php on line 770
Strict Standards: Declaration of mosDMDocument::save() should be compatible with that of JTable::save() in C:\joomla\administrator\components\com_docman\docman.class.php on line 770

Is this something that I should be concerned about and try to fix the problems or is it only to set the error reporting to simple and hope that everything is OK?

Greetings

Peter

Answer

Posted 8 years ago by Johan Janssens Staff

Peter, This is not something to be concerned about. This is not an error message, but a special notice for developers to inform them that their code isn't using PHP 5.3 strict standards yet. The messages are only shown when you turn error reporting on Maximum or on Development.

You will find these messages with many Joomla extensions that have not been made PHP5.3 strict yet. In Joomlatools all our new extensions are, our older extensions are not.

There are 2 more comments in this ticket.
Subscribe or login to join the discussion!

Peter Åman
10.10.12
Answered

System Information

n/a
n/a
n/a
n/a