Joomlatools Support Center

Fileman 3.0 and Docman 2.1.5 together ? No !

Hello,

I want to install FileMan 3 (and Logman 3) on a website who have logman 2.1.2 , fileman 2.1.5, extman 2.2.4 and docman 2.1.5

And I have a error message :

Warning

Your site has DOCman 2.1.5 installed. You will have to upgrade it first to the latest 3.0 version before any other of our extensions since they all share the same underlying framework. Please go to https://joomlatools.com to download DOCman 3.0 first.
Extension Install: Custom install routine failure.

So I must install Docman 3.0 but is it 99% stable, because, as I can see, it is a RC1 ?

Thank you.

Regard.

Answer

Posted 3 years ago by Johan Janssens Staff

Hello Xavier, all our extensions use the same base framework. You cannot mix 2.x and 3.0 extensions on the same site, they will conflict with each other.

If you run multiple extensions on the same site you need to upgrade all of them together. DOCman 3 RC is production ready, a second RC is released tomorrow. I suggest you use that.

If you are not sure you can always wait for the stable to be released in a few weeks.

Does that help you?

There are 5 more comments in this ticket.
Subscribe or login to join the discussion!

xavier prost
18.10.16
Answered

System Information

2.1
3.6
7
n/a